Golang 遇到 note module requires Go 1.nn 解决之道,不升go

遇到note: module requires Go 1.17,或者 note: module requires Go 1.18 等报错该如何是好呢?可能你会搜索到很多升级Go版本的答案。有没有想过揪出到底是哪个包导致了升级呢?有不用升级Go版本的办法,想试试么?

在使用多版本的golang的小伙伴,往往会遇到这个问题。本文就如何不升级 go 版本来解决该问题。

怎么产生的

  1. 同时使用IDE和命令行,命令行go版本和IDE的go不是同一个版本。
  2. 多人协作同一个项目,别人使用不同版本的go加入了一个包且写入了一个较高版本号。
  3. go get 时选择了较高版本。

网上的大部分解决方案都是升级自己的go版本。那么如果不想升级有办法解决么?

不升Go版本

例如我遇到了:

# golang.org/x/sys/unix
../../go/pkg/mod/golang.org/x/sys@v0.3.0/unix/syscall.go:83:16: undefined: unsafe.Slice
../../go/pkg/mod/golang.org/x/sys@v0.3.0/unix/syscall_darwin.go:95:8: undefined: unsafe.Slice
../../go/pkg/mod/golang.org/x/sys@v0.3.0/unix/syscall_unix.go:118:7: undefined: unsafe.Slice
../../go/pkg/mod/golang.org/x/sys@v0.3.0/unix/sysvshm_unix.go:33:7: undefined: unsafe.Slice
note: module requires Go 1.17

尝试把 go.sum 删掉,再 go mod tidy 还是没用,依然报这个错。

这时看看 go.mod 文件

module github.com/PaulXu-cn/xxx

go 1.15

require (
    github.com/go-faker/faker/v4 v4.0.0-beta.4
    github.com/golang/protobuf v1.5.2
    github.com/snksoft/crc v1.1.0
    github.com/spf13/cobra v1.6.1
    github.com/spf13/viper v1.15.0
)

也就是说当前我的 go runtime1.15 的,
是引用了基于 go1.17 的包,需要把这个包降为依赖 go1.15的即可。那这里的哪个包需要降版本呢?

该项目简单,只有5个直接依赖,可以通过依次删除添加测出来,如果有很多依赖的话,又该怎么解决呢?

包后面带 // indirect 是间接依赖,删掉这一行不影响。
参考 https://go.dev/ref/mod

上工具

这里介绍个工具 gmchartgo mod 图像化展示工具 —— https://github.com/PaulXu-cn/go-mod-graph-chart

进入工作项目

cd goProejct

安装 gmchart

$ go install github.com/PaulXu-cn/go-mod-graph-chart/gmchart@latest

运行

$ go mod graph | gmchart
go mod graph version v0.5.3
the go mod graph will top in 60s
visit it by http://127.0.0.1:59760

go mod graph 是官方工具命令。 可展示出了该项目所有的依赖关系,只不过是文本形式展示,输出的内容多了,人眼看不出啥来。这里借用 gmchart 工具,可以将其依赖关系组织为 树状 渲染 web 页面,也就是和go 工具一样,跨平台的。

利用工具找问题

回到我们刚刚的报错啊, golang.org/x/sys 包依赖了 go1.17.

这里我们搜一下啊

search1

呦,一共有84个,我们再把版本号输入进去,缩小范围

search2

好的,定位到了1个,那就是它了,然后呢?

看了看 go.mod , 好像我们也没有直接引用它,要去 go.mod 删也没有得删。

如果是如下情况,带有 indirect 注释的,删除了也不能解决问题!

require(
    golang.org/x/sys v0.3.0 // indirect
)

这里有大聪明,建议我去 go.sum 里面去删,这是没用的哈,go mod tidy 一下又回来了。

找出直接依赖

  1. 用工具找到具体包
  2. 在界面中点击包
  3. 查看所有引入了该包的 包。这里我们看到了5个包,viper这个包是直接依赖,因此该调整这个包的版本

search_gif

serach_gif_mark

  1. 在 github 上找到 viper https://github.com/spf13/viper
  2. 打开 go.mod —— https://github.com/spf13/viper/blob/master/go.mod

viper_master

这里通过查看 vipergo.mod ,发现最新的 viper 已是基于 go1.17 , 我的项目 go get 了最新版本的 viper,所以,编译时就会报错——note: module requires Go 1.17

这里按理说不会拉取高版本的 viper,但这里是切换了go版本,导致了该情况。

  1. 项目要求是不高于 go1.15,那就依次便利 viper 的各个tag。好——viper@1.9.0 是当前版本最高且要求不高于 go1.15 的。https://github.com/spf13/viper/blob/v1.9.0/go.mod

  1. 把项目中 go.mod, 依赖—— viper 版本改为 v1.9.0 报错就解决了。

总结

我最近在做项目时,切换 go 版本遇到了该问题,顺手查了下,发现网上的答案都是让其升级 go 版本,其实就是依赖高版本的第三方包,这里借用工具,找出该包,通过降第三方包的方式也能解决该问题。

如果大家遇到同类问题,不想升go版本,可以试试改方案。

没有遇到也没关系,收藏一下,某天遇到了不想升go可以再翻出来看看

qrcode

参考

  • https://go.dev/ref/mod
  • https://github.com/PaulXu-cn/go-mod-graph-chart

Cannot create namespace centrum.policy in multi-document transaction.

Cannot create namespace centrum.policy in multi-document transaction.

Cannot create namespace xxx.xxx in multi-document transaction.

问题

看报错信息,就是说不能在 mongo 事务中创建表。

解决否

已解决

方案

这是说: 不能在事务中创建 collection 。但你一看 sql,没有创建表语句啊。

mongo 中,如果你操作的 collection 不存在是会自动创建的。但有个例外就是事务。

在事务中是无法创建表结构的。

所以,解决这个问题,就是在执行 mongo sql 前,先创建好要操作的 collection

参考

  • https://stackoverflow.com/questions/52585715/cannot-create-namespace-in-multi-document-transactionmongodb-4-0-spring-data-2

Mongo 副本集 选择副本后 连不上 server selection error

failed: server selection error: context deadline exceeded, current topology: { Type: ReplicaSetNoPrimary, Servers: [{ Addr: 127.0.0.1:27017, Type: Unknown, Last error: connection() error occurred during connection handshake: dial tcp 127.0.0.1:27017: connect: connection refused

Mongo 副本集 选主错误 server selection error

问题

failed: server selection error: context deadline exceeded, current topology: { Type: ReplicaSetNoPrimary, Servers: [{ Addr: 127.0.0.1:27017, Type: Unknown, Last error: connection() error occurred during connection handshake: dial tcp 127.0.0.1:27017: connect: connection refused

解决否

已解决

方案

登陆 mongo server 输入命令

rs.status()

rs.status

这里看图片里,name是: mongolab:27021, 那么应用也会用这个地址去连 mongodb,如果 dns 里没有 mongolab,那么应用是连不上这个 mongo 的,最终报错就是链接超时。

查看一下Mongo集群之间的通讯 IP,或者地址是怎么配置,是否配置的IP的应用端能访问的IP段。

例如,三个 mongo 集群配置在同一网段内—— 192.168.1.0 ,如果你也按照这个 IP 来配置副本集,那么 mongo 之间通信是没问题的,但如果应用端可能读取 replica 信息后,会那副本集配置的 IP 信息去访问其他节点,这个时候应用会拿着 192.168.1.0 这个网断的 IP 去访问 mongo,如果 mongo 和应用不在一个网段,就会导致如上问题。所以,mongoreplica 配置的IP也需是应用可访问的 IP

这也是,往往运维部署,发现,mongo 互通 OK,运维溜了。等应用来连,却连不上问题。

参考

  • https://www.mongodb.com/docs/manual/replication/
  • https://www.mongodb.com/docs/manual/reference/method/rs.initiate/

【已解决】Laravel Class encrypter does not exist No supported encrypter found. The cipher

Laravel 报错加密类找不到。Class encrypter does not exist. No supported encrypter found.

Laravel 5.1 加密类找不到问题

Laravel 项目运行时,报错:

No supported encrypter found. The cipher and / or key length are invalid
Class encrypter does not exist

刚开始以为是,加密拓展没装好,实际上是app密钥没生成、配置到位。

解决否

已解决

方案

点断点, 断到: \Illuminate\Encryption\EncryptionServiceProvider::register

发现读取了配置,配置里面的 key 没初始化。

$ php artisan key:generate

$ php aritsan config:cache

生成的 key 要写入到配置文件里。这配置一般是在 /app/config.php 目录里,实际请按照个人项目来。

这里报错就是因为,随便写了一个字符串,长度不符合key的40长度,导致报错密钥长度不够。